Hanalyzer now runs from SAP NW 7.00

Hanalyzer bases its analysis on SAP Code Inspector, SCI, and we use the latest static checks, which requires a minimum of SAP NW 7.02(SP 14), SAP NW 7.03/7.31 (SP9) or SAP NW 7.4 (SP2). But many customers have not installed the latest service packs or they are running a lower SAP release, such as NW 7.00, which in truth challenged our team for some time.

This has now been solved so we support any SAP release from NetWeaver 7.00 and up.

The way we handle older versions is by using SAP Standard remote static checks run from a standalone SAP NW 7.4 SP8 or higher. The programs are extracted and imported into the standalone server — either via RFC or simply as a zip file.

The standalone server runs the code inspection and the ZHanalyzer program then formats and transports the inspections to Gekkobrain Hanalyzer for the actual HANA or S/4 HANA analysis and assessment.

The illustration below shows a standard Hanalyzer setup for SAP systems running NetWeaver 7.4 (SP2), NetWeaver 7.03/7.31 (SP9), NetWeaver 7.02 (SP14).

Using remote static checks for older versions of SAP, the Hanalyzer setup is done according to the illustration below.

Gekkobrain for SAP HANA - conceptual architecture

The only prerequisite is that SAP note 2011106 is installed on the source system.

We have run a successful client installation and it worked flawlessly.

For more information about this particular setup, please take a look at SAP’s help portal here or contact us.

search previous next tag category expand menu location phone mail time cart zoom edit close